Schlagwort-Archive: WENNFEHLER

Tipps & Tricks für Excel – Tipp 044: Einfacher Fehler abfangen mit WENNFEHLER

Wenn eine Formel oder Funktion in Excel einen Fehler liefert sollte sich dieser nicht als Fehlerwert in der Zelle zeigen (z. B. #WERT!), sondern benutzerfreundlich abgefangen werden.

Dazu gibt es seit Excel 2007 die Funktion WENNFEHLER. Vorher musste dazu ein
verschachtelter Ausdruck mit der WENN-Funktion und meist der ISTFEHLER-Funktion benutzt werden, was verhältnismäßig aufwendig war.

Die Funktion lässt sich so beschreiben:
=WENNFEHLER(Wert;Wert_falls_Fehler)

Beispiel: die Formel =A1/B1 führt bei einer leeren Zelle B1 zu dem Fehler #DIV/0!
Soll in dem Falle die Ergebiszelle einfach leer bleiben heißt der passende Ausdruck:
=WENNFEHLER(A1/B1;““)

Das erste Argument gibt also die auszuführende Formel oder Funktion an, das zweite
die Aktion, die im Falle eines Fehlers ausgeführt werden soll.

Beispiel mit der SVERWEIS-Funktion:
=WENNFEHLER(SVERWEIS($A$1; A5:H100; 2; FALSCH); „Kunde existiert nicht.“)
In der Zelle A1 steht eine Kunden-Nr., mit der in der Matrix A5:H100 ein Firmenname
zurückgegeben werden soll. Wird die Kunden-Nr. nicht gefunden, wird in die Ergebniszelle der Text „Kunde existiert nicht.“ geschrieben.

Viel Erfolg bei der Anwendung.